Benutzer-Werkzeuge

Webseiten-Werkzeuge


java_eclipse:entwicklungsumgebung_einrichten:mac_os:eclipse_3.6.2

Achtung! Diese Anleitung ist veraltet. Bitte nutzen Sie folgende Anleitung: Installation von Eclipse 4.4.1

Installation von Eclipse 3.6.2 (deprecated)

Voraussetzungen

Eclipse installieren

Download und entpacken

Die „Terminal.app“ öffnen und die folgenden Befehle ausführen:

bash.sh
cd ~/Applications
curl -O http://archive.eclipse.org/eclipse/downloads/drops/R-3.6.2-201102101200/eclipse-SDK-3.6.2-macosx-cocoa-x86_64.tar.gz
tar xfz eclipse-SDK-3.6.2-macosx-cocoa-x86_64.tar.gz
mv eclipse eclipse-SDK-3.6.2
rm eclipse-SDK-3.6.2-macosx-cocoa-x86_64.tar.gz

Eclipse starten, einen beliebigen Workspace wählen und auf die Workbench wechseln.

Plugins einrichten

Web Tools

Plugins Unter „Help→Install New Software…“ die folgenden Plugins installieren:

  • „Work with:“ Helios - http://download.eclipse.org/releases/helios auswählen
  • Unter „Web, XML, and Java EE Development“ die folgenden Plugins auswählen:
    • Eclipse Java EE Developer Tools
    • Eclipse Web Developer Tools
    • Eclipse XML Editors and Tools
    • JavaScript Development Tools
    • JST Web UI
    • PHP Development Tools (PDT) (Optional, nur wenn Sie auch in PHP programmieren)
  • Die ausgewählten Plugins installieren & Eclipse neustarten

Subversion

SVN Unter „Help→Install New Software…“ die folgenden Plugins installieren:

  • Unter „Available Software Sites“ das Repository „http://download.eclipse.org/technology/subversive/0.7/update-site/“ auswählen
  • „Work with:“ http://download.eclipse.org/technology/subversive/0.7/update-site/ auswählen und die folgenden Plugins installieren:
    • Subversive Revision Graph (Optional) (Incubation)
    • Subversive SVN Team Provider (Incubation)
  • Eclipse neustarten
  • SVNKit Version 1.3.6 bei der Perspektive auswählen und installieren

Encoding auf UTF-8 umstellen

Unter „Eclipse→Einstellungen→General→Workspace“ Text file encoding auf UTF-8 stellen.

Formatierung einstellen

  • Unter „Eclipse→Einstellungen→General→Editors→Text Editors“ Show line numbers aktivieren.
  • Unter „Eclipse→Einstellungen→Java→Code Style→Formatter“ ein neues „profile“ anlegen. (Optional)
  • Unter „Eclipse→Einstellungen→XML→XML Files→Validation“ Indicate when no grammar is specified auf „Ignore“ setzen.
  • Unter „Eclipse→Einstellungen→Validation“ Classpath Dependency Validator den Haken bei „Build“ entfernen.

JDK 6 integrieren

Dieser Schritt ist optional und richtet sich an Anwender, die mehrere/unterschiedliche JDK-Versionen verwenden.

  • Unter „Eclipse→Einstellungen→Java→Installed JREs“ auf „Add…“ klicken.
  • „Standard VM“ auf „Next“ klicken
    • JRE home: /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home
    • JRE name: JDK 6.0
  • Das „JDK 6.0“ als Default auswählen.

Tomcat-Libraries integrieren

  • Unter „Eclipse→Einstellungen→Java→Build Path→User Libraries“ auf „New…“ klicken.
    • User library name: Tomcat 7.0
  • Unter „Add JARs…“ sämtliche Libraries von „~/Library/Tomcat/Home/lib/“ auswählen

SVN Repository einbinden

  • Die Perspektive „Window→Open Perspective→SVN Repository Exploring“ öffnen.
  • Über Rechtsklick auf „New→Repository Location“ klicken.
  • Unter „General“ die folgenden Einstellungen vornehmen:
    • URL: (%USERNAME entsprechend anpassen)
      svn+ssh://127.0.0.1/Users/%USERNAME/Library/Subversion/LocalRepository
    • Use a custom label: Local Repository
    • Authentication entsprechend Username & Passwort einsetzen

SVN

Fertig

Eclipse ist erfolgreich installiert & konfiguriert. Sie können jetzt Ihre erste Webapplikation erstellen…